After the fix, an instance of Magento\CatalogSearch\Model\Indexer\Fulltext class can be created without specifying $data. After this fix applied when multiple product price 0 and we load category page at frontend it wont throw any exception and will load category page successfully. Previously, with the configuration ticket mentioned, when we put price 0 for multiple products, it will throw an exception at the frontend category page. Now Special Price bulk update API will create a single campaign for each date range instead of multiple scheduled updates for each product and date range. After the fix, product’s tier prices returned for graphql requests have price per one item.
The error message has been removed to improve the storefront UX, ensuring customers can still view their past returns. Now, a proper error message is returned if https://best-adobe-commerce-cloud-agencies.com/ a non-existing attribute is requested. Fixed the issue where the customer query returned an internal server error when a deleted custom attribute still had a stored value.
Previously, CSS related to disabled modules was included in the final CSS output files, leading to the loading of extra, unnecessary styles. The system now excludes CSS related to disabled modules from the final CSS output files, ensuring that unnecessary styles are not loaded. The system now generates source maps for less files when in developer mode, making it easier to identify the source of a style.

more articles about ecommerce

When a graphQL request for an item with insufficient quantity was made, a proper error message with an error code was returned, and if the requested quantity is available, the cart update was successful. GraphQL calls to place an order for a nonexistent or inactive cart now correctly return CART_NOT_ACTIVE or CART_NOT_FOUND error codes in all store views, fixing an issue where translated error messages previously resulted in an UNDEFINED code. Improved customer address telephone validation to support values up to 255 characters, aligning server-side checks with database limits.

  • The system now supports process fork for MView indexation, preventing errors during indexer execution when operating on multiple threads.
  • Previously to the fix some unit tests failed due different library versions or due to missing functionality added in a later version.
  • Fixed an issue where refreshing the order page did not display the latest customer custom attribute data; after the fix, updated attribute values are now reflected without needing to cancel and recreate the order.
  • You may need to visit a Post Office to complete certain customs forms or for specialized USPS services, such as bulk mailings or services for businesses.
  • The system now correctly validates and imports product CSV files containing special characters, allowing for successful data transfer.

Multi-Store from One Admin Panel

Now, the selected options are retained, allowing the product to be added to the cart smoothly without prompting users to reselect options. Prior to the implementation of this correction, the cart price rule for multi-shipping products did not apply correctly when sub-select conditions were applied and free shipping was enabled. Previous to the fix mixins would not have loaded in cart and checkout when minify and bundling enabled.
The system now supports the use of created_at, status, and grand_total filters in customer Orders queries, and has resolved an issue where multiple filters were not being applied correctly. Previously, running the re-index command resulted in a “Catalog Search index process error during indexation process” error when PHP was compiled with certain versions of libxml. Previously, the presence of a 0-byte image in the media gallery would prevent all images in the directory from being displayed or selected. Previously, expanding the ‘Image and Videos’ tab first resulted in the folder tree not being displayed and an error message when attempting to upload an image in the WYSIWYG editor. Previously, the “Using Default value” message was not displayed, leading to confusion about the status of the selected theme. PHPSESSID no longer regenerates on POST requests on frontend area for a logged-in customer if L2 Redis cache is enabled and the customer was updated from the backend

Research Assistant III Bar Murphy, hailing from Dolbeau enjoys watching movies like “Hound of the Baskervilles, The” and Ice skating. Took a trip to Historic City of Ayutthaya and drives a Ferrari 275 GTB/4 ART Spyder Alloy.

Leave a Reply